Gughi

Installazione su spazio con certificato SSL

Recommended Posts

Gughi    0

Buonasera, ho visto un precedente post sull'argomento ma io ho problemi con l'installazione e non riesco a risolverli. Sto tentando di installare Contao su uno spazio dpove ho attivato il SSL, ma già la prima schermata di Install mi appare senza css e quando inserisco l'install password vengo avvisata che mi trovo su una connessione non sicura (?) e non succede nulla, la password si resetta e stop.

Il provider comunica che può essere necessario aggiungere i seguenti comandi al file .htaccess

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTP_HOST} ^www.
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]

 

Ho provato ma evidentemente non inserisco correttamente e non funziona ugualmente.
Esiste un file predisposto per Contao che possa scaricare e caricare e andare sul sicuro?

Grazie mille!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PaoloB    0

Anche se sul tuo dominio è attivo un certificato SSL puoi accedere al sito anche con protocollo http standard.

Per cui se proprio hai problemi, prova a digitare semplicemente il dominio senza https.

Successivamente puoi modificare il file .htaccess in modo che anche se qualcuno accede in http, questo viene forzato ad https.
Come regola io uso semplicemente

  RewriteCond %{HTTPS} off
  RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Gughi    0

Grazie Paolo, il fatto è che c'è l'impostazione delle redirezione automatica sul server e quindi vengo reindirizzata ugualmente su https...

Posso provare a disattivare questa opzione...

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PaoloB    0

beh, se c'è la ridirezione automatica, allora non devi fare nulla di particolare su Contao. Dovrebbe essere trasparente.
Vuoi mandarmi il link in privato che guardo il tipo di errore!?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Gughi    0

Per chi dovesse riscontrare lo stesso problema (Contao non rilevava l'utilizzo del protocollo https) PaoloB ha risolto aggiungendo al file system\config\initconfig.php l'istruzione seguente.

if (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && 'https' === $_SERVER['HTTP_X_FORWARDED_PROTO']) {
    $_SERVER['HTTPS'] = 1;
}

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PaoloB    0

Il problema era che nell'hosting del dominio, non veniva rilevato che vi era una connessione https e fogli di stile venivano inserito in http standard.
In questo modo non venivano caricati.

Abbiamo quindi aggiunto un comando per indicare in modo forzato che la connessione è https.
 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Gughi    0

Sì, anche se sono migliorati rispetto al passato reagiscono sempre come il famoso muro di gomma.
Purtroppo si è diffusa la convinzione che l'hosting non debba costare più di pochi euro e quando presento le varie opzioni ai clienti non c'è verso di far scegliere qualcosa di più professionale.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora